GE Monogram stove ignitor keeps clicking


  #1  
Old 06-24-24, 06:00 PM
R
Member
Thread Starter
Join Date: Jun 2024
Posts: 6
Upvotes: 0
Received 0 Upvotes on 0 Posts
GE Monogram stove ignitor keeps clicking

I have a ZDP30N4. It's a 4 burner NG stove. Problem is with the front right burner. All burners spark, light, and operate normally. When the front right burner is off, its red light keeps pulsing and the ignitor for all burners keeps clicking and sparking. When the front right burtner is on, there is no clicking.

I have cleaned the ignitor with alcohol, there is no obvious debris around any ignitors, have not recently gotten any of the burners wet. I also ran the burner over night at the lowest setting. Nothing has worked so far.

Any ideas what might be going on? Thanks!
 
  #2  
Old 06-25-24, 01:41 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,972
Received 4,149 Upvotes on 3,726 Posts
Welcome to the forums.

That would probably be a problem with the spark module.
I'm trying to locate service info but it looks like it needs to e purchased and downloaded,

Still looking.
 
  #3  
Old 06-25-24, 08:57 PM
R
Member
Thread Starter
Join Date: Jun 2024
Posts: 6
Upvotes: 0
Received 0 Upvotes on 0 Posts
Hello and thank you. I am hopeful you are able to find something!
I have resorted to turning the breaker on and off as needed which is not very fun.
 
  #4  
Old 07-07-24, 08:28 PM
R
Member
Thread Starter
Join Date: Jun 2024
Posts: 6
Upvotes: 0
Received 0 Upvotes on 0 Posts
Hello PJmax, just wondering if you were able to find anything. Thank you.
 
  #5  
Old 07-08-24, 07:53 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,972
Received 4,149 Upvotes on 3,726 Posts
The service manual below should be close enough to your ZDP-30N4.

Download it and let me know when you have it. I don't leave them posted.
I would like you to disconnect/unplug the RF switch on the gas control to see if problem remains.
If it does... you'll need to replace the spark module.
I'm fairly certain the module is causing the problem.
Search using part number.

GE WB13T10078..... 4pt ign module
RI230C-4G .............. 4 pt ign module
 
Attached Images
File Type: pdf
GE Monogram.pdf (1.85 MB, 5 views)
  #6  
Old 07-10-24, 08:06 AM
R
Member
Thread Starter
Join Date: Jun 2024
Posts: 6
Upvotes: 0
Received 0 Upvotes on 0 Posts
Hello, Pete. I just downloaded the service manual. Many thanks. I will try the RF switch disconnect and let you know how it goes. To clarify, are you asking me to disconnect the cable housing connected to the backside of the knob of the clicking burner which is located behind the front panel. Is that right?

Thanks again for your help.
 
  #7  
Old 07-10-24, 06:53 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,972
Received 4,149 Upvotes on 3,726 Posts
Yes... that's correct.
Once the switch is eliminated ..... that just leaves the module.
 
  #8  
Old 07-13-24, 07:27 PM
R
Member
Thread Starter
Join Date: Jun 2024
Posts: 6
Upvotes: 0
Received 0 Upvotes on 0 Posts
I finally got a drill bit small enough to remove the plate. I disconnected the knob for that burner and the clicking has totally disappeared. All other burners still working fine. What do you suggest for next steps? Thank you.
 
  #9  
Old 07-14-24, 05:23 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,972
Received 4,149 Upvotes on 3,726 Posts
There are letters missing off your posted model number.

You unplugged the igniter switch and the errant spark stopped.... replace the switch.
It looks like it uses part # WB24X10091 igniter switch.
You can search using that part number. It's widely available.

WB24X10091
 
  #10  
Old 07-14-24, 08:35 PM
R
Member
Thread Starter
Join Date: Jun 2024
Posts: 6
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thank you, Pete. Clear.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: