Swamp Cooler Problem


  #1  
Old 10-07-02, 02:32 PM
caseyfern
Visiting Guest
Posts: n/a
Question Swamp Cooler Problem

Didn't see any other swamp cooler questions in this area - I do hope this is the right forum spot!

Windowmount (side draft) swamp cooler emits a 'green' smell if pump is turned off more than a few minutes.

We've tried replacing pump, pads, spiders - bleach into the water pan (all we got was green stinky bleachy smell).

Once pump is turned on and cool mode is selected, the problem will dissipate over a few hours. Meanwhile it's pretty sickening and is making us all sneeze (and believe me you do not want to watch two cats sneezing constantly). Doesn't matter if it's high summer or dead of winter.. same effect.

I'm really not in a position to yank the whole thing out and replace it with a brand new one - any suggestions, experiences in this direction or bright ideas very welcome!
 

Last edited by caseyfern; 10-07-02 at 03:03 PM.
  #2  
Old 10-07-02, 03:12 PM
bigjohn
Visiting Guest
Posts: n/a
If you've already tried removing it, stripping it down and thoroughly cleaning with it bleach, then I would say pitch it. There has to be a slime/mold buiildup in it somewhere.
 
  #3  
Old 10-07-02, 03:25 PM
caseyfern
Visiting Guest
Posts: n/a
Ugh... somehow I had a feeling that would be the response .. what sort of replacement cost is reasonable for a sidedraft swamp cooler? Never bought one, and this one came with the house several years ago. Just don't want to get the usual run-around I get at hardware stores (many see the grey haired female and instantly assume 'sucker').
 
  #4  
Old 10-07-02, 03:43 PM
bigjohn
Visiting Guest
Posts: n/a
Have you tried thoroughly cleaning it first? I don't have an idea on price, perhaps you could try an internet search.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: