ignition is dead & furnace to

Reply

  #1  
Old 02-18-04, 10:28 AM
Member
Thread Starter
Join Date: Jun 2003
Location: las cruces, NM
Posts: 51
ignition is dead & furnace to

Help I have plm. My furnace does nothing no sounds.
It's a lennox with self ighition & I got the thermostat up to 78 & nothing
My wife called a repairman to come but we really can't afford one.
I can see the big blue igniter # G776RGD-11.
I opened the damper (carefully) and looked & can't see where the light would
light. It's a race against time before he get's here or I can call.
any help is helpful.
Dabear
 
Sponsored Links
  #2  
Old 02-18-04, 10:43 AM
Member
Thread Starter
Join Date: Jun 2003
Location: las cruces, NM
Posts: 51
add on

I forgot to say the furnace is about maybe 4 yrs old
Dabear
 
  #3  
Old 02-18-04, 10:52 AM
imjerry
Visiting Guest
Posts: n/a
Quick simple reply

Did you check fuses or Circuit breakers, also furnace safety switch if there is one?? Often shut off by accident!!

Post back for more info
 
  #4  
Old 02-18-04, 10:59 AM
Member
Thread Starter
Join Date: Jun 2003
Location: las cruces, NM
Posts: 51
yes

yes I checked the circuit breaker & put in a new fuse
now if the safety switch is on the side of the unit yes it's on
on the igniton control there is a green light that is not on
dabear
 
  #5  
Old 02-18-04, 01:32 PM
Member
Thread Starter
Join Date: Jun 2003
Location: las cruces, NM
Posts: 51
Back to being warm yeahhhh!

The repairman came & it was a circuit board that was bad & still under warranty so
all I had to pay was house call & labor.
So this was something that you guys could not help, only to tell I needed someone else
to look at it.
Anyway thanks for looking.
Dabear
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes