lennox G23 pilot problem

Reply

  #1  
Old 03-03-04, 05:15 AM
jcon
Visiting Guest
Posts: n/a
lennox G23 pilot problem

Hi! I've got a lennox G23(x) gas furnace. I'm having pilot problems. First I replaced mechanical thermostat with programmable one but I didn't change jumper on BCC Blower control board from mechanical thermostat to electric thermostat.It's been at least a year. I switched jumper when problem started. Now I'm having problems with the pilot control. It's a Johnson Controls " Intermittent Pilot Control (IPI). The LED code says "1 sec/5 sec off" In retry period. LED shuts off after couple minutes. Fans shut off after about 5 minutes. Did I screw something up by not changing jumper. If so what went might have gone bad? the pilot control? I can fire up furnace by shutting it all down and following the initial start up. But next cycle it won't light. I also have a White Rodgers 36E Gas Valve.


any ideas, no big hurry, I'm in Chicago, weathers been pretty mild. just cool at night! ...........thanks, jcon
 
Sponsored Links
  #2  
Old 03-03-04, 04:44 PM
rclhvac
Visiting Guest
Posts: n/a
Johnson Controls Intermittent Pilot Control (IPI) is bad needs to be relpaced
 
  #3  
Old 03-11-04, 05:00 PM
jcon
Visiting Guest
Posts: n/a
thanks rclhvac that was it!. replaced pilot control, and working fine!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: