Lennox Gas Furnace Problem

Reply

  #1  
Old 02-20-05, 06:42 AM
DoYoHoMe
Visiting Guest
Posts: n/a
Question Lennox Gas Furnace Problem

We have a Lennox gas furnace; it was working fine until I went on a vacation for more than a month. Before I left, I set up the system at the lowest settings, which is 50-55. Now since I got back home, it has been giving me a trouble, when I turn the system on it starts as it should be, but it throws a cold air, so I opened the cover from the furnace to see what is the problem, well there is a blue color box (control box) that lights up then I hear the click and pilot flame comes out, that hits igniter (looks like a pin) and I see gas flame starts pumping the flame through the burners/tubes, but in couple of seconds it stops, meaning the gas flames disappears, I only hear a motor of some kind running, not the fan, but something runs continuously.

I called local dealer who said it could be a flame sensor that needs to be clean or it could be the blue box itself. I don't have a manual for this so I have no clue where is the flame sensor is located. I tried to clean the igniter, pilot and there is the 3rd pin I believe that could be a thermocouple, but it didn't make any difference. Please help if someone who knows or having a same condition, it is cold out there and I am concern about plumbing pipes going to explode
 
Sponsored Links
  #2  
Old 02-20-05, 08:58 AM
mattison's Avatar
Member
Join Date: Mar 2003
Location: Cinti, OH
Posts: 5,549
Received 0 Votes on 0 Posts
That Lennox should have a diagnostic code light on it that will flash a code that corisponds to a legend on the panel.

How does the pilot light ? Is it acomplished via a spark??

The one downside of owning a Lennox is that if you find the problem you will more than likely still have to call a Lennox dealer to get the part for you. Lennox is one of the hardest for homeowners to get parts for.
 
  #3  
Old 02-20-05, 09:55 AM
DoYoHoMe
Visiting Guest
Posts: n/a
Thanks for replying, The model # it says G23Q3/4 but also says on the duct that is extending from the furnace model C26-41-1. under the furnace there is a control box by Johnson controls G776RGD-2 IPI also says # 69J3601 and part # 4,931,975. The green color light comes on as soon as I turn the system on, that is the only light there from what i see and it is located on the this blue control box. There are many wires there, but one white wire connects to what i believe is the igniter (that i broke while cleaning ) then rubber tube is i believe is connected to the thermocouple and then the silver metal tube is for gas and it is the one connected to the pilot. I am wondering where the flame sensor is, because the service man said just clean the flame sensor and 85% of th time it works.

I went to the Lowes and Home Depot, they suggested to go to the near by plumbing supply, but they are closed.

mj
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: