Furnace blower keeps running - Lennox furnace.

Reply

  #1  
Old 10-12-06, 11:21 AM
Member
Thread Starter
Join Date: Oct 2006
Posts: 2
Upvotes: 0
Received 0 Votes on 0 Posts
Furnace blower keeps running - Lennox furnace.

I have a Lennox (Pulse21) furnace with the following problem: the blower continues to run after the heating unit shuts down. No matter if I put my fan in 'auto' or 'on' at the programmable thermostat, the blower keeps running. Also, if I flip the 'heat', 'cool', 'off' switch to any of these positions, the blower continues to run. It has been eventually shutting off after a long period of time (anywhere from 1-5? hours).

Is there any relay/switch that could be causing this problem or does anyone have any suggestions?

Thank you very much.
troy
 
Sponsored Links
  #2  
Old 10-12-06, 04:08 PM
Jay11J's Avatar
Member
Join Date: Sep 2001
Location: Rochester, Minnesota
Posts: 18,427
Upvotes: 0
Received 0 Votes on 0 Posts
It has been ages since I been around these.. They are no longer made..

If I recalled, on the upper left hand side, there is a fan control/limit. It's a round dial, you should have 3 tabs.

1st tab fan off
2nd tab fan on
3rd tab Limit.

What is on and off temp set at?
 
  #3  
Old 10-13-06, 11:22 AM
Member
Thread Starter
Join Date: Oct 2006
Posts: 2
Upvotes: 0
Received 0 Votes on 0 Posts
1st tab=95
2nd tab=130
3rd tab=180

FYI - the blower seems to be running correctly today. Moving the fan to on/auto is working correctly. This problem seems to be quite sporadic. Sometimes it will work (shut off after the heat shuts down) and sometime it won't (fan keeps on going).

Thanks for your help.
 
  #4  
Old 10-13-06, 11:37 AM
Ed Imeduc's Avatar
Member
Join Date: Aug 2002
Location: Mountain Williams Missouri
Posts: 18,389
Upvotes: 0
Received 0 Votes on 0 Posts
Wink

Try and push the 1st tap fan off up to 100 and Id bring the fan on down to 120

ED
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes