New Goodman Furnace Ignition Problem


  #1  
Old 01-06-07, 03:12 PM
R
Member
Thread Starter
Join Date: Jan 2007
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
New Goodman Furnace Ignition Problem

Recently completed the hook-up on a Goodman GMS9 Gas furnace.
Everything seems to be in order - but no ignition. This furnace was uncrated about 1 1/2 years ago and sat in its location - not connected since then. Per Troubleshooting Chart all of the probable causes for "furnace fails to operate" have been eliminated and I don't want to turn it over to the HVAC guy when it is probably something very simple.

Any suggestions would be appreciated.
 
  #2  
Old 01-06-07, 04:30 PM
KField's Avatar
Member
Join Date: Dec 2002
Location: Easton, PA
Posts: 3,245
Upvotes: 0
Received 0 Upvotes on 0 Posts
If it got banged around the ignitor could be bad. Otherwise check venting. Depending on model there may be safety pressure switches that monitor draft and prevent ignition if enough is not present. Good luck. You know the warranty clock started ticking 1 1/2 years ago.

Ken
 
  #3  
Old 01-06-07, 05:31 PM
R
Member
Thread Starter
Join Date: Jan 2007
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thanks Ken.

Igniter glows very bright so I'll go make sure the vent is moving enough air.

Just blew out the orifices and then attempts to fire produced a "new" clicking noise in the pressure switch about the time the gas should have ignited. ???
 
  #4  
Old 01-06-07, 06:37 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 14,403
Received 39 Upvotes on 37 Posts
No Igniton

Has air been purged from the gas line? Gas pressure checked? Set up for the right kind of gas (natural or LP)? Gas shut off valve & gas valve in furnace turned on? HVAC guy should be doing the start up.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: