Beckett/Weil Mclain won't fire after reset...


  #1  
Old 02-09-07, 12:48 PM
G
Member
Thread Starter
Join Date: Feb 2007
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Beckett/Weil Mclain won't fire after reset...

I'm not 'new' to Oil furnaces, but not super experienced either, at dignosing things...

I DO clean my own furnace, and replace the nozzle...

We rented out our house, and the tenants called and mentioned the furnace isn't running.... he hit the reset button, and the motor ran, but it did not fire... i'm assuming the 1st thing to check would be:

1. Fuel coming from the bleed valve,

2. if there's fuel, change the nozzle

3. If still doesn't fire, it would be the ignitor?

or is there an easier way to tell?

thanks all!!

J
 
  #2  
Old 02-09-07, 04:23 PM
G
Member
Thread Starter
Join Date: Feb 2007
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Ah....solved for now...Air in the line ( i did ask if they had run it out....)

if anyone has any thoughts on the above question, they still stand..

thanks all..

J
 
  #3  
Old 02-09-07, 04:34 PM
Ed Imeduc's Avatar
Member
Join Date: Aug 2002
Location: Mountain Williams Missouri
Posts: 18,386
Likes: 0
Received 1 Like on 1 Post
Wink

for sur tell them to not hit the reset button more than 3 times ..... Then stop
The oil filter , clean and reset the electrodes, check the psi on the pump. Every year

# 3 check the transformer
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: