50A50 Controller Question

Reply

  #1  
Old 10-28-07, 11:48 AM
Member
Thread Starter
Join Date: Oct 2007
Posts: 1
Received 0 Votes on 0 Posts
50A50 Controller Question

Have a Trane XE 90 w/ WR 50A50-474 controller. Combustion and ventilation fans run but no heat. On start up the diagnostic light flashes fast (Normal. Call for heat) and the combustion fan starts. After ~ 30 seconds the ventilation fan starts and the diagnostic light goes to continuous on (Internal Control Failure - Replace).

Is this diagnostic reliable? In other words is there anything else I should check before buying a new controller? I understand that the current replacement unit is 50A55-843; any tricks on installing it or does it pretty much swap right into the existing wiring?

Thanx -
 

Last edited by Grady; 10-28-07 at 04:45 PM. Reason: Deleted E-Mail address
Sponsored Links
  #2  
Old 10-28-07, 03:55 PM
Jay11J's Avatar
Member
Join Date: Sep 2001
Location: Rochester, Minnesota
Posts: 18,427
Received 0 Votes on 0 Posts
Please remove your e-mail address on the board.. Thanks!

Anyway, to your question, most board I've changed out are pretty easy swap out.

Just make sure you make NOTES of what wires went where!

The codes are pretty good with what the trouble is.

Have you shut down the power to the furnace for a few min, and try again?
 
  #3  
Old 10-29-07, 10:50 AM
Member
Join Date: Aug 2007
Posts: 2,021
Received 0 Votes on 0 Posts
Originally Posted by Diogenes View Post
Have a Trane XE 90 w/ WR 50A50-474 controller. Combustion and ventilation fans run but no heat. On start up the diagnostic light flashes fast (Normal. Call for heat) and the combustion fan starts. After ~ 30 seconds the ventilation fan starts and the diagnostic light goes to continuous on (Internal Control Failure - Replace).

Is this diagnostic reliable? In other words is there anything else I should check before buying a new controller? I understand that the current replacement unit is 50A55-843; any tricks on installing it or does it pretty much swap right into the existing wiring?

Thanx -
!. Go to www.whiterodgers.com scroll down and click in peoducts then look up furnace conntrols and look the 50A55-843 module. You'll find a catalog page, install instuctions and a troubleshooting guide. The guide would apply to your module. You'll notice on the troubleshooting guide that the diagnosis is reliable as long as the flame sensor is not shorted to ground. Translation- pull the flame sensor out to see if the ceramic is cracked. if that's ok and the problem comes backa fter a reset replace the module.

2. The w/r cross reference says the 50A55-843 will replace your module. Look at page 3 of the install instuctions, for Trane units you have to install a jumper that comes with the kit, so be sure not to miss that.


It's interesting that your "spider-sense" told you to ask around. he he http://arnoldservice.com has the 50A55-843 for $115. However, he says that it won't replace 50A50-xxx modules, but that does not agree with what w/r says. www.myhavcparts.com has them for $169
 
  #4  
Old 11-16-08, 12:51 PM
Member
Join Date: Nov 2008
Posts: 1
Received 0 Votes on 0 Posts
Sorry to drag this thread up but my situation is very related. I am getting the replacement board 50A55-843 and am comparing to the bad board I have now, to make certain of an easy swap.

Every lines up great from my old 50A50-206 *except* the plug that has the IND/IGN items.

The old board has only a 2 space plug for IND and IGN
The new board has a 4 space IND/IGN/IND-N/IGN-N

So, I am sorta stumped. If I can get a blank 4 space plug and just wire it with the IGN and IND wires...will it still work?

THANKS!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: