Carrier 58SSB080-BC "Clicking" at startup

Reply

  #1  
Old 01-28-08, 01:05 PM
G
Member
Thread Starter
Join Date: Jan 2008
Posts: 4
Received 0 Votes on 0 Posts
Question Carrier 58SSB080-BC "Clicking" at startup

Replaced main board, no difference.
Replaced pressure switch, no difference
Replaced Inducer circuit board, no difference
Replace draft inducer motor last year, worked fine (old one was noisy)
Initially, service people replaced igniter coil, worked for 1/2 day.
When he was here, he "wiggled" harness connector at Inducer board, started, we cleaned contacts, thinking it was it.
I 'wedged' a thin wood shim behind connector, worked for a week.
Bottom line is, is my gas valve bad, limit switch, pilot assy?
Before they come back and charge jizillions per hour to do what I did, I'd like to narrow it down to keep costs down.
 
Sponsored Links
  #2  
Old 01-28-08, 01:42 PM
J
Member
Join Date: Oct 2005
Location: USA
Posts: 1,076
Received 0 Votes on 0 Posts
We could use a little more info. Does the unit just click and nothing else? Does the draft inducer motor start up? Does the blower work? Does the unit spark and attempt to light the burners?
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: