Goodman furnace doesn't work

Reply

  #1  
Old 03-12-08, 08:15 PM
Member
Thread Starter
Join Date: Mar 2008
Posts: 2
Upvotes: 0
Received 0 Votes on 0 Posts
Goodman furnace doesn't work

My furnace is about 5 years old. It doesn't give any heat out since yesterday. I used digital thermostat.
Here is what I found so far:
1. Air conditioning is working fine (cool).
2. When I set fan to "on", it does blow out the air.
3. when I set my desired temperature at very high( like 95 deg) and fan to "auto" mode at "heat" mode, Neither air or heat coming out.
4. The manual says this furnace doesn't have pilot, it has an device to auto ignite the burner

Then I opened the thermostat and tried the following:

1. connect red(RH) and White(W), the blower under the burner seems "on" but I didn't see air out from duct.
2. connect red(RH) and green(G), I can feel air coming out of duct but no heat still.

Anyone can give me any hint how to fix it? Is it thermostat problem or furnace issue?

Thanks.

Jack
 
Sponsored Links
  #2  
Old 03-13-08, 02:53 AM
pflor's Avatar
Member
Join Date: Dec 2007
Location: U.S.A.
Posts: 1,127
Upvotes: 0
Received 0 Votes on 0 Posts
Pls provide the full model number of this goodman furnace.

The problem is not on your thermostat.

Do not turn the cooling mode ON during cold weather (winter) unless you live in FL, CA or TX, else you risk damaging the compressor $$$
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes