GMP075-3 furnace will not light

Reply

  #1  
Old 10-24-08, 06:47 AM
Member
Thread Starter
Join Date: Oct 2008
Posts: 1
Received 0 Votes on 0 Posts
GMP075-3 furnace will not light

Hi,
I have a Goodman GMP075-3 REV B furnace. The ussual operation is the vent blower starts, the ignitor lights and the gas comes on. Sometimes the sensor gets dirty and I have to clean it but, this time the vent blower does not start and the ignitor does not light but, the furnace fan does start. When this is happening the "status" indicator light on the curcuit board in RED. Not flashing - just solid red.
Can anyone help me understand what this means and how to fix/ bypass?

Thanks!
 
Sponsored Links
  #2  
Old 10-24-08, 07:23 AM
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,629
Received 0 Votes on 0 Posts
Shut off the furnace and wait about 30 seconds, then turn it back on, for it to reset. Then we can diagnose the problem, from there.
 
  #3  
Old 10-24-08, 07:39 AM
Member
Join Date: Sep 2008
Location: NY
Posts: 433
Received 0 Votes on 0 Posts
Bypass - only for diagnostic purposes; fix - perhaps.

After a reset, check to see if the tstat is calling for heat by checking voltage across heat (Y) to common (C).

Are you getting power to the draft inducer (vent blower as you call it). If so check for blockage or remove and see if it can free wheel.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: