York Furnace Intermittent Lighting Issue


  #1  
Old 11-17-08, 10:17 AM
N
Member
Thread Starter
Join Date: Nov 2008
Posts: 5
Upvotes: 0
Received 0 Upvotes on 0 Posts
York Furnace Intermittent Lighting Issue

Hi

I have a York Hot surface ignitor furnace. I have this issue where the burners would not light up even though the ignitor turns red. The thing works most of the time but I see this issue every 2-3 days.

1> Blower Starts
2> Ignitor lights up
3> I hear a click in the valve and the burners light.

However step 3 does not happen at times and after 3 attempts there is a lockout. If I recylce, it soetimes works. The furnance did not work all of yesterday but today it starte dup fine. Once it starts up i do not see the issue for 2-3 days.

I am thinking the valve may be hosed. Or is there is loose connection somewhere?

Any pointers will be very appreciated. The tech just quoted me $300 (including labor) for replacing the valve.
 
  #2  
Old 11-17-08, 06:11 PM
E
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 7,826
Upvotes: 0
Received 1 Upvote on 1 Post
Even when the burner does not light up, do you at least notice the click sound? If in doubt, and you are on natural gas, go out and look at the 1/2 foot dial on your gas meter and see if it turns during, or you noticed it moved after, these ignition attempts were made. The gas should flow, even without fire, for about up to 4 seconds.

Suppose it does, then you could have a weak ignitor. Or the gas is not coming out fast enough, near the ignitor, due to some clog.

Suppose the meter does not move at all. You then need to test to see if 24 volts is getting to the gas valve terminals when that click should be occuring.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: