Coleman Evcon furnce won't stay lit

Reply

  #1  
Old 12-19-08, 08:11 AM
Member
Thread Starter
Join Date: Dec 2008
Location: Southwest
Posts: 1
Received 0 Votes on 0 Posts
Coleman Evcon furnce won't stay lit

Howdy: I hope that this request is in the right place, forgive me if it's not.
I have an older (50s) home with a Coleman Evcon gas furnace with a Robert Shaw control package. A few years ago the unit started having problems related to the HSE which I replaced followed by the thermal switch and the controller. Now the control unit ( which I have just replaced ) a Fenwal series 35-65 unit is cycling properly, running for 30 seconds or so, single flashing (no call for heat) and recycling. I cannot get the burners to cycle longer than a minute. The burner blower is running as is the fan but the controller shuts down the valve and the whole cycle repeats. Needless to say the house does not get very warm. I would welcome any assistance that i could get.
 
Sponsored Links
  #2  
Old 12-19-08, 10:09 AM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 13,936
Received 1 Vote on 1 Post
Short Cycling

If you have not replaced or done anything to the thermostat, there's no reason to believe it is your problem BUT let's take it out of the picture right off the bat. Remove the thermostat & jumper together the wires going to terminals RH & W (ususally red & white). Watch the furnace & if the problem goes away, the stat was indeed the problem. If not, post back & we'll see what else might be going on.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: