I really don't know what I'm talking about...

Reply

  #1  
Old 04-23-09, 07:15 PM
J
Member
Thread Starter
Join Date: Apr 2009
Posts: 2
Received 0 Votes on 0 Posts
I really don't know what I'm talking about...

Sorry, I really don't know what I'm talking about, but I'll try and explain.
If your looking at my furnace there is a little red motor to the side of it and when I bought the house 7 years ago, the little old lady who we bought the house from told us to make sure we drop a few drops of oil in there every 4-5 months. Lately, when the heat goes on and the little red motor starts running it sounds awful like something is rubbing and now there is a slow drip of a liquid thats like water.(not oil)
Any ideas if this sounds like it needs to be replaced or whats causing these sudden problems?
 
Sponsored Links
  #2  
Old 04-23-09, 09:07 PM
P
Temporarily Suspended
Join Date: Jul 2008
Location: NY
Posts: 10,986
Received 0 Votes on 0 Posts
It sounds like the circulator pump needs to be replaced.
 
  #3  
Old 05-02-09, 01:54 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 14,247
Received 23 Votes on 21 Posts
Circulator Pump

I think Pulpo is right. If it is leaking water the shaft seal is probably the culprit & not repaceable. A picture of the leaking device would certainly help. You can post pictures on photobucket.com or similar site & provide a link here.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: