Beckett Oil Furnace Won't Start


  #1  
Old 09-22-09, 02:04 PM
A
Member
Thread Starter
Join Date: Sep 2009
Location: Oklahoma
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Beckett Oil Furnace Won't Start

This looks like an informative forum, so here goes...

I have a Beckett AFG Oil Burner, installed in 1997, that won't start. Normally every year the furnace starts when called upon. I have checked AC power, I have clicked the manual fan switch, and the fan runs just fine. Normally pushing the reset causes the furnace to cycle, but not today. Silence.

I have looked at new ignitors, but they appear smaller than mine, which is large and has the large red reset button. Mine is large square, and has the red button on top. Underneath, there are two copper strips, not the coil springs I see on the new models, is this an update?

New Models...

 
  #2  
Old 09-23-09, 01:40 PM
P
Temporarily Suspended
Join Date: Jul 2008
Location: NY
Posts: 10,982
Likes: 0
Received 0 Likes on 0 Posts
When was the last time that the filter was changed? Have you tried to prime the line? Is the tank underground?
 
  #3  
Old 09-23-09, 09:23 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 14,401
Received 38 Likes on 36 Posts
Copper Strips?

I can't recall Beckett ever using copper strips on their ignition transformers. Are you sure the burner is a Beckett or are you just looking at the ignition transformer? Beckett makes ignition transformers to fit many different burners & all their transformers will have the Beckett name on them regardless of the brand of burner.

If the thermostat was calling for heat, you pressed the reset button, & nothing at all happened, the ignitior is not your problem.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: