Gas furnace burner won't light, also short cycles


  #1  
Old 12-07-09, 12:51 PM
P
Member
Thread Starter
Join Date: Aug 2006
Location: Texas
Posts: 25
Upvotes: 0
Received 0 Upvotes on 0 Posts
Gas furnace burner won't light, also short cycles

We have a Janitrol gas furnace that is probably 15 years old. The pilot lights and stays light, but the main burner will not light. We hear the igniter clicking and buzzing, and then after about a minute, it gives up and stops. If we fan or blow on the front of the furnace during the buzzing of the igniter, the main burner will light, and the furnace will run. It does blow hot air and works good once we get the burner lit. However, it usually won't run until the temp is reached - it'll go up 2-3 degrees then the fan stops, it'll relight the main burner, and then the fan blows again - continuing this 2-3 times to raise the temp say, 8 degrees. My husband tried cleaning the flame sensor but that didn't seem to help.

Suggestions?
 
  #2  
Old 12-07-09, 02:44 PM
SeattlePioneer's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2007
Location: Seattle, Wa
Posts: 4,469
Upvotes: 0
Received 1 Upvote on 1 Post
What is the model number of the furnace?
 
  #3  
Old 12-07-09, 05:55 PM
P
Member
Thread Starter
Join Date: Aug 2006
Location: Texas
Posts: 25
Upvotes: 0
Received 0 Upvotes on 0 Posts
I looked at the sticker inside and it says Model GUI 125 5A Rev S.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: