Tappan Furnace not heating


  #1  
Old 12-14-10, 02:15 PM
T
Member
Thread Starter
Join Date: Dec 2010
Location: USA
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Tappan Furnace not heating

Hello my gas furnace is not heating and I checked the ceramic ignition switch and it is fine. Does anyone have any ideas? thanks
 
  #2  
Old 12-14-10, 02:28 PM
lawrosa's Avatar
Super Moderator
Join Date: Dec 2010
Location: Galivants Ferry SC USA
Posts: 15,993
Received 85 Upvotes on 77 Posts
Hi we can help. What make and model? What type of fuel gas, oil, propane? Do you have your manual? Do you see any lights flashing at a control box? Your manual will tell what they mean.

Lets us know as much info as you can. Whats it doing what its not doing.


Mike NJ
 
  #3  
Old 12-15-10, 08:52 AM
T
Member
Thread Starter
Join Date: Dec 2010
Location: USA
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
I own a TAPPAN furnace "FG6RA 072C -12A" that runs on Natural Gas there is a flashing red light, but I don't have the manual and am currently looking for it online. Again I remove and checked the igniter for cracks, I also removed and cleaned the flame sensor with steel wool. and turned the gas off for a few hour because it said to try that on the panel door instruction. It is a single red flash about every two seconds continuosly. The back of the panel says a continues flasing light is "false flame or gas valve relay shorted"

Thanks
 

Last edited by TheBigLaubowski; 12-15-10 at 10:03 AM.
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: