Luxaire furnace not igniting


  #1  
Old 03-09-11, 08:04 AM
riggstad's Avatar
Member
Thread Starter
Join Date: Jan 2010
Location: Philly Burbs
Posts: 155
Upvotes: 0
Received 0 Upvotes on 0 Posts
Luxaire furnace not igniting

5 Year old luxaire furnace that is rigged for propane has a 4 red light flashing code (which the manual states the limit switch is open) and won't ignite.

Turned it off and on and it starts up and lights up for a few minutes then reverts back to the error code.

I checked for loose wiring and it's not working. Is this for a pro to come out or is this an obvious fix I am missing.

I can and will post more info and pics if needed... Thanx!
 
  #2  
Old 03-09-11, 08:19 AM
SeattlePioneer's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2007
Location: Seattle, Wa
Posts: 4,469
Upvotes: 0
Received 1 Upvote on 1 Post
The limit switch opening suggests that the furnace isn't able to get rid of the heat the burners are producing, so it get hotter and hotter until shut off by the limit switch.

The most common reason for this is a lack of adequate airflow through the furnace in a forced air furnace.

Common reasons for this are:

Plugged air filter

Too many warm air vents closed

Return air vents covered over or plugged

Plugged air conditioner evaporator coil in the furnace

fan motor not starting or not coming up to speed

fan wheel broken or plugged with dirt or debris.

ductwork collapsed or insulation loose and plugging the duct work
 
  #3  
Old 03-09-11, 10:34 AM
riggstad's Avatar
Member
Thread Starter
Join Date: Jan 2010
Location: Philly Burbs
Posts: 155
Upvotes: 0
Received 0 Upvotes on 0 Posts
All those things check out. I can't be sure if the switch is bad or even how to check if it is but all the above things are good.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: