ThermoPride afg oil burner issue


  #1  
Old 04-08-11, 08:44 PM
O
Member
Thread Starter
Join Date: Dec 2010
Location: usa
Posts: 33
Upvotes: 0
Received 0 Upvotes on 0 Posts
ThermoPride afg oil burner issue

hey oil burner acting up again i came home to a blinking becket genysys7505burner control unit so i reset it usually kicks back but it didnt so did prime bled it until go full flow but didnt kick so i left it alone figured id get at it another time so i went back to bleed it the flame lit up when i was bleeding but alot of smoke was coming out of hole where to check flame and it was kinda rumbling so i turned it off right away becuase there was alot of smoke coming out when i turned it off it went off right away what should i do i think it may be some left over oil in the burner it was burning off should i try to run it again or what??
 
  #2  
Old 04-09-11, 12:22 AM
O
Member
Thread Starter
Join Date: Dec 2010
Location: usa
Posts: 33
Upvotes: 0
Received 0 Upvotes on 0 Posts
nevermind it worked fine when i retried bleeding it just a lil leftover oil burning off i think i got a dirty oil tank problem but anyway thanx
 
  #3  
Old 04-09-11, 07:15 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 12,682
Received 41 Upvotes on 39 Posts
If you think you have a dirty tank it certainly wouldn't hurt to change the filter & pump screen, and flush the fuel system before installing a new nozzle.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: