Flame won't stay lit


  #1  
Old 04-20-11, 09:52 AM
M
Member
Thread Starter
Join Date: Apr 2011
Location: USA
Posts: 4
Upvotes: 0
Received 0 Upvotes on 0 Posts
Flame won't stay lit

I have a Ruud Achiever 90 plus. It is about 5 yrs. old. When the furnace kicks on it keeps either blowing the flames out or it is shutting it down. Both fans will run but there is no flames. I have cleaned out what I can, I have shut it down and even shut the gas off at the shut off. I then resarted everything and it is still the same. What do I do?? How do I fix this?? No money for a repairman!!
 
  #2  
Old 04-20-11, 10:22 AM
M
Member
Join Date: Dec 2004
Location: San Jose,Ca
Posts: 1,277
Upvotes: 0
Received 3 Upvotes on 3 Posts
Look for the "flame rod" next to the burner farthest opposite the igniter and wipe it off with steel wool, paper, dollar bill, just about anything. you don't need to sand it, just clean it.
 
  #3  
Old 04-20-11, 10:36 AM
M
Member
Thread Starter
Join Date: Apr 2011
Location: USA
Posts: 4
Upvotes: 0
Received 0 Upvotes on 0 Posts
Ok, I cleaned the ignitor rod and it ticks and then lights but then the flames go out again. The big fan keeps running. When I turn off the power and turn it back on the big fan kicks back on. Still can't get the flame to stay on.
 
  #4  
Old 04-20-11, 02:40 PM
M
Member
Thread Starter
Join Date: Apr 2011
Location: USA
Posts: 4
Upvotes: 0
Received 0 Upvotes on 0 Posts
Well not really sure what I did or if it is going to keep working but as of now the furnace is working and it is toasty warm in the house. Thanks for all the advice. you guys rock!!!
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: