Goodman GSM flashing light


  #1  
Old 09-15-11, 08:36 AM
D
Member
Thread Starter
Join Date: Sep 2011
Location: usa
Posts: 2
Received 0 Votes on 0 Posts
Goodman GSM flashing light

Turned on my 12 year old Goodman GSM furnace for the first time this season and the red light on the HSI module is flashing continuously, does not go into ignition or purge mode nor does the combustion blower start, but 5 seconds later the furnace blower starts and runs, no heat . Troubleshoot code says Twinning-Check Polarity. Not using TWIN term, unit is standalone. 115 power to board ok with correct polarity, HSI fuse good, draft inducer/purge motor turns manually-not forzen. Recent work was new gas valve last year. Other than that unit has been trouble free. Grateful for any help.
Thank You, Dave
 
  #2  
Old 09-15-11, 02:32 PM
hvactechfw's Avatar
Member
Join Date: Jan 2011
Posts: 6,244
Received 2 Votes on 2 Posts
Check you ignitor............
 
  #3  
Old 09-16-11, 12:52 PM
D
Member
Thread Starter
Join Date: Sep 2011
Location: usa
Posts: 2
Received 0 Votes on 0 Posts
Update Goodman Flashing Light

The Main Module was defective. I painstakingly checked ever component, limit switches, purge motor, coils, gas valve..... everything but the flame sensor. Since it never got to ignition I figured the flame sensor wouldn't cause a continuous flashing light. SO by elimination it had to be the module. Got it the next day from an online vendor. Best price out there and free shipping overnight. Hardest part installing new wiring loom that came with upgraded board.
Thanks to those who replied..Dave
 

Last edited by hvactechfw; 09-16-11 at 03:46 PM. Reason: removed advertisement for website
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: