Furnace issues


  #1  
Old 02-06-12, 12:30 PM
M
Member
Thread Starter
Join Date: Feb 2012
Location: USA
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Furnace issues

My furnace runs constantly without producing any heat. I replaced my thermostat with no luck. Furnace is a Carrier 58GS050-AA. Any suggestions will be appreciated.
 
  #2  
Old 02-06-12, 03:49 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 12,682
Received 41 Upvotes on 39 Posts
Many furnaces have a small "window" in the blower door thru which you can view a, usually blinking, light on the control board. If yours has such a window & you can see the blinking light, count the blinks the remove the door. On the inside of the door is often a sticker which decodes the blinks.
 
  #3  
Old 02-06-12, 03:54 PM
M
Member
Thread Starter
Join Date: Feb 2012
Location: USA
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Re: Furnace issues

Grady, thanks for the rapid response! I believe the furnace is the original furnace that came with the house (1989), and does not appear to have any "electronics".
 
  #4  
Old 02-06-12, 03:58 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 12,682
Received 41 Upvotes on 39 Posts
If the furnace has not been serviced in the past couple of years, you need to contact a local service company & have it done. Oil burners should be serviced annually or no less frequently than every other year. BTW, Honeywell makes only controls, not furnaces.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: