Problem with Magic Chef Furnance blower


  #1  
Old 11-17-12, 05:24 PM
S
Member
Thread Starter
Join Date: Feb 2011
Location: USA
Posts: 4
Upvotes: 0
Received 0 Upvotes on 0 Posts
Problem with Magic Chef Furnance blower

Model # G7A75DC10-9. The blower runs fine when it's turned on but when on auto it won't run. I think it's the blower relay. Am I right or is it something else?

Thanks, Jeremy
 
  #2  
Old 11-18-12, 06:43 AM
hvactechfw's Avatar
Member
Join Date: Jan 2011
Posts: 5,491
Upvotes: 0
Received 4 Upvotes on 4 Posts
it is likely a relay or a fan limit.
 
  #3  
Old 11-18-12, 03:15 PM
L
Member
Join Date: Nov 2012
Location: USA
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Fan Relay

I doubt if it is the fan relay as the relay is still used when you to fan on (Manual). The fan on just pulls the fan relay in so as to run the 110 Volts to the Fan. The thermostat control is normally 24 volts. If you are getting the fan to run in manual mode off the thermostat and not in Auto I would say the problem may be more in the fan limit switch or on some models it will be in the control board that brings the fan on after a certain amount of time. Hope for a fan limit switch as the control board can get expensive.
 
  #4  
Old 11-18-12, 03:37 PM
hvactechfw's Avatar
Member
Join Date: Jan 2011
Posts: 5,491
Upvotes: 0
Received 4 Upvotes on 4 Posts
there is no fan control board on this furnace. It also uses different speeds for heating and fan on (a/c)
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: