Coleman D.E.S. 80 (Model 2865-E666) - Ignites, but blower doesn't push air


  #1  
Old 12-23-12, 01:37 PM
Z
Member
Thread Starter
Join Date: Dec 2008
Posts: 3
Received 0 Votes on 0 Posts
Coleman D.E.S. 80 (Model 2865-E666) - Ignites, but blower doesn't push air

Hello,

I have a Coleman D.E.S. 80 (Model 2865-E666, Natural Gas) forced air heating unit. I can hear the burner click and ignite and feel the metal getting hot, so I surmise that it is burning OK. However, although I "think" that I hear the fan working (although it might just be the noise of the burner), there is NO air coming out through the registers.

I changed batteries in the thermostat, with no improvement. I changed the thermostat, still no change. Could anyone help with diagnosing what the problem could be? The unit is about 14 years old and has worked reliably all the time. Next to it I have an identical unit (for the other part of the house), same vintage, same model, which works perfectly.

I would appreciate any help! Temperature is in the mid-thirties here in California and this is NOT shaping up to be a "warm Christmas"! Please help!

Thank you,

Cal
 
  #2  
Old 12-24-12, 12:38 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 70,122
Received 2,961 Votes on 2,672 Posts
If you think you hear the blower running but don't feel any air movement.......you may have a clogged filter.
You should be able to remove filter access cover and feel air movement there.

Another way to check for blower activity is to turn thermostat down below room temperature and place in FAN ON mode.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: