trouble with furnace need help


  #1  
Old 01-15-13, 07:41 PM
T
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 218
Upvotes: 0
Received 0 Upvotes on 0 Posts
trouble with furnace need help

early 90's duomatic olsen intermittent ignition furnace.
had been acting up and working sometimes.

now the ignitor doesnt work. It clicks like gas valve opens but no ignition.
After a bit the fan kicks on and runs.

I changed the relay. If I turn the furnace on, when I hea the click I can light it manually. It will stay on for about 1-2 minutes then burners shut down but fan stays on. It didnt get up to thermostat temp in doing this.

any help would be great, its cold inside. using other heaters temporary.
 
  #2  
Old 01-15-13, 08:14 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,415
Received 4,048 Upvotes on 3,631 Posts
It would be great if you could give us a model number. Should be behind main access door.

Ignitor not working is a problem.
What relay did you change.
 
  #3  
Old 01-16-13, 05:46 AM
T
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 218
Upvotes: 0
Received 0 Upvotes on 0 Posts
I will get the model number Later
The relay was for the fan. What would seem to happen before is furnace would heat and run correctly but the fan would stay on until we shut it off as room temp would drop. So furnace has new relay and fan switch
Now the ignitor don't spark at all. I can light the burners with grill lighter so I don't think it's a gas valve. Do the wire for spark go bad often? Looks like spark plug wire and plugs
 
  #4  
Old 01-16-13, 02:03 PM
T
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 218
Upvotes: 0
Received 0 Upvotes on 0 Posts
duomatic olsen furnace
model # HCA100ND4R

has intermittent pilot electronic ignition.
 
  #5  
Old 01-17-13, 11:21 AM
SeattlePioneer's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2007
Location: Seattle, Wa
Posts: 4,469
Upvotes: 0
Received 1 Upvote on 1 Post
What is the make and model of the ignition control module?
 
  #6  
Old 01-17-13, 07:39 PM
T
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 218
Upvotes: 0
Received 0 Upvotes on 0 Posts
Its a Honeywell. S86H Intermittent spark
 
  #7  
Old 01-27-13, 04:43 PM
T
Member
Thread Starter
Join Date: Sep 2004
Location: usa
Posts: 218
Upvotes: 0
Received 0 Upvotes on 0 Posts
furnace is working.

It was a bad control module. The old module had 110v coming out of the plug wire connector from the module, but it wouldnt make the constant tick tick tick noise when lighting the pilot. Replaced module one wire needed switched to another spot on the module which wa tricky.
had 2 spots saying 24v
new on had both saying 24v but had one below that saying th-m and thats where the one wire needed to go. just was different from original.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: