HELP!! Lennox G40UH(X) Series Furnace - Stopped Working


  #1  
Old 01-17-13, 12:29 AM
J
Member
Thread Starter
Join Date: Jan 2013
Location: USA
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
HELP!! Lennox G40UH(X) Series Furnace - Stopped Working

Today my Lennox G40UH(X) Series Furnace stopped working.

_ I confirmed my thermostat is set to HEAT

- The thermostat temp is showing 59 and I tried setting it to 65 but nothing happens.

- Then I tried turning the blower on (at the thermostat) and again nothing happened.

- I checked the circuit breaker at my main breaker panel and it is OK.

- I checked the power switch on the side of the furnace and it is in the ON position.

- I peered into the window where the two diagnostic LEDs are located and they are both off.

I turned the gas off now just to be safe.

Anything else I can try or is it time to call for service?

Thanks so much for any help!!!
 
  #2  
Old 01-17-13, 04:41 PM
hvactechfw's Avatar
Member
Join Date: Jan 2011
Posts: 6,244
Likes: 0
Received 4 Likes on 4 Posts
Both LED off sounds like a power issue.
 
  #3  
Old 01-18-13, 12:34 AM
J
Member
Thread Starter
Join Date: Jan 2013
Location: USA
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
thanks for your reply; we suspected a power issue too. paid for a service call. they came out pretty quickly but made some mistakes in troubleshooting the issue. long story short, after disconnecting and reconnecting the door kill switch, everything started working fine again. tech thought it might be an intermittent door switch...I'm not so sure so I decided to skip replacing it but it will be the first place I look if this happens again.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: