Trianco Furnace - Beckett (somethign) shuts off after 20 seconds


  #1  
Old 01-17-13, 05:21 PM
J
Member
Thread Starter
Join Date: Jan 2013
Location: united states
Posts: 32
Likes: 0
Received 0 Likes on 0 Posts
Trianco Furnace - Beckett (somethign) shuts off after 20 seconds

This morning my Trianco oil furnace wasn't running.. I hit the red reset button and it turned on for 20 seconds and shut off again. Did that twice.

Saw I was low on oil and got oil today.. bled one cup of oil through the bleeder and turned it back on and it does the same things. Shuts off after 20 seconds...

Seems like it doesn't want to ignite? Has a beckett whatever where the oil goes through..

Gonna be cold here tonight in PA any ideas on why it keeps shutting off? and how to fix it?
 
  #2  
Old 01-17-13, 05:34 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 14,401
Received 38 Likes on 36 Posts
You've already pushed the reset button too many times. It's time to call a pro. Be sure to tell him/her what you've done. Does the fire actually ignite or is just the motor running?
 
  #3  
Old 01-17-13, 05:56 PM
J
Member
Thread Starter
Join Date: Jan 2013
Location: united states
Posts: 32
Likes: 0
Received 0 Likes on 0 Posts
motor runs for 20 seconds.. then shuts off? what is it?
 
  #4  
Old 01-18-13, 04:43 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 14,401
Received 38 Likes on 36 Posts
It is failing to ignite which means every time you are pushing that reset button, you are pumping more & more oil into the chamber. Should it ignite at some point, you could have more of a problem than you bargained for. CALL A LOCAL PRO
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: