Grrrrr Noise on starting gas furnace and no operation


  #1  
Old 05-18-13, 01:21 PM
K
Member
Thread Starter
Join Date: Aug 2010
Location: INDIA
Posts: 13
Upvotes: 0
Received 0 Upvotes on 0 Posts
Grrrrr Noise on starting gas furnace and no operation

I have Trane XR80 -TUD100C948K0 gas furnace. It was working fine till last month and then stopped throwing heat suddenly. I called a technician , who charged me 90 dollars for analysis, 90 for igniter cost and 90 for labor (total 270 dollars just to replace igniter ;-)). Just after 34 days of that, now I am getting only noise on furnace start, blower won't start.
I kept furnace off for 3-4 days and then gave a try y'day again on cool mode, it started by making same grrrrr noise for 2 seconds. But after an hr, it stopped and kept making same grrrrrr noise.

Will it be an igniter issue again ? Called technician, but he said since it is more then 30 days, he will recharge me again. I don't want to call that technician again.

Could it be a capacitor issue ?

Any help is appreciated.
 
  #2  
Old 05-19-13, 01:07 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 65,935
Received 4,139 Upvotes on 3,717 Posts
I called a technician , who charged me 90 dollars for analysis, 90 for igniter cost and 90 for labor (total 270 dollars just to replace igniter
30 day warranty ?!?!?!? That's pretty sad. Service was one of the few strong points of this country. Now that seems to be going down the tubes too.

Not an ignitor problem. Definitely could be a starting cap problem with the blower.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: