Trane Model BLU108F Lights but trips breaker

Reply

  #1  
Old 10-25-13, 07:34 PM
Member
Thread Starter
Join Date: Oct 2013
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
Trane Model BLU108F Lights but trips breaker

My Trane Model BLU108F Lights and heats but when the fan should turn on the breaker trips. The A/C runs fine.
 
Sponsored Links
  #2  
Old 10-25-13, 10:49 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 54,227
Received 479 Votes on 449 Posts
Welcome to the forums.

Does the breaker trip when you put the thermostat in FAN ON mode ?

If it does then you have to check the blower motor. Either the motor or the wiring has a short.
 
  #3  
Old 10-26-13, 04:53 PM
Member
Thread Starter
Join Date: Oct 2013
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
no the fan runs, and the a/c also runs fine
 
  #4  
Old 10-27-13, 07:37 AM
Former Member's Avatar
Member
Join Date: May 2006
Location: US
Posts: 782
Received 0 Votes on 0 Posts
Kicks breaker

I believe that model runs a different fan speed in heat and AC you have lost the windings in the blower fan for the heat speed. Replace the blower motor. (check the wiring first of course for a short but most likely a new motor is in order)
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: