Armstrong Tech 80 intermittent lighting


  #1  
Old 11-19-13, 04:45 PM
T
Member
Thread Starter
Join Date: Nov 2013
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Armstrong Tech 80 intermittent lighting

Thanks in advance...

I have an Armstrong Tech 80 furnace that lights intermittently after it's been sitting for about 8 hours. Once the Thermostat calls for heat, the inducer fan will turn on for just a second or so, then it shuts off. The diagnostic code flashes 3 times. I can turn on/off the T stat and the furnace will cycle thru the same way with the inducer fan starting, then it turns off.

But, if I continue to turn the T stat on/off about a dozen times or so, it will eventually light and operate fine, and once it does eventually fire, it will start normally and work fine for the rest of the night.

I have already replaced the gas valve, but that didn't cure it. Everything else works fine once it gets thru the cycle of shutting off the inducer fan.

What's the next step?
 

Last edited by Tall Bob; 11-19-13 at 05:13 PM.
  #2  
Old 11-19-13, 05:57 PM
Houston204's Avatar
Forum Topic Moderator
Join Date: Oct 2009
Location: Texas
Posts: 6,530
Received 95 Upvotes on 88 Posts
http://www.armstrongair.com/_/pdfs/i..._506526-01.pdf

3 flashes = pressure switch lockout

Check for faulty wire connections between the board and your induced draft motor.

Check for 120 volts to the inducer when a demand is present.
 
  #3  
Old 11-20-13, 07:08 AM
T
Member
Thread Starter
Join Date: Nov 2013
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thank you. I'll look into that and get back.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: