Beckett psc motor/fan runs continuously (even with no stat)


  #1  
Old 11-28-13, 12:31 PM
M
Member
Thread Starter
Join Date: Nov 2013
Location: Canada
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Beckett psc motor/fan runs continuously (even with no stat)

Hello, 6 year old furnace worked fine till one hot summer night this year our pump/psc motor (not the blower fan) turned on by itself. The stat was in the off position (no a/c installed) I shut the main breaker off and left it till now.

Turned the main breaker on yesterday and psc motor starts up. I disconnected the t-stat leads = still runs. I reconnect t-stat leads call for heat the system runs normal. I call for heat, it fires up, blower fan goes through it regular sequence, shuts down, psc motor keeps running.

Ive disconnected the blocked vent safety switch, the psc motor stops. tried resetting the primary control = no dice. The light is always off unless I call for heat then it turns on but does not flash.

I have a Clare OLB-03 oil furnace with a beckett burner and a r7184b primary.


Any help would be greatly appriciated
 
  #2  
Old 11-28-13, 02:33 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 12,682
Received 41 Upvotes on 39 Posts
If you disconnected the thermostat wires at the primary control & the motor still runs, you have a bad primary.
 
  #3  
Old 11-28-13, 03:31 PM
M
Member
Thread Starter
Join Date: Nov 2013
Location: Canada
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thank you for your quick reply. already ordered an updated primary.

Have a good day.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: