Go Back  DoItYourself.com Community Forums > Heating, Cooling, Air Conditioning, Ventilation and T-Stat Controls > Gas and Oil Home Heating Furnaces
Reload this Page >

old ThermalZone outdoor furnace/ac combo unit - hot surface igniters shatter

old ThermalZone outdoor furnace/ac combo unit - hot surface igniters shatter


  #1  
Old 12-02-13, 10:56 PM
L
Member
Thread Starter
Join Date: Dec 2013
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
old ThermalZone outdoor furnace/ac combo unit - hot surface igniters shatter

I have an ancient ThermalZone model PG036K096-1B ? (I think - the sticker is incredibly faded). The symptoms have changed a few times. At first it was heating but no fan. I discharged and checked the run capacitor, and then it worked for a while when I put it back in - not sure why. A week later another problem - nothing happens after the draft inducer runs. I saw that my hot surface igniter was cracked, so I replaced it. When I started it up after the draft inducer did its thing the igniter started glowing extremely bright and shattered. Thinking it may just be a faulty part I exchanged it. The same thing happened again.

Is the control board is sending to much voltage to that? Since the blower won't operate at all now can I assume that these two symptoms are caused by a bad control board? Are control boards fairly universal? Like I said the unit is very old and I can't find any documentation for this old model and replacement part lists. Thank you so much for your insight!
 
  #2  
Old 12-05-13, 08:38 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 12,682
Received 41 Upvotes on 39 Posts
With this being a combination unit, it is possible you are getting 240 volts to the ignitor instead of the normal 120. There are some "universal" boards out there which replace many but not all control boards.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: