Furnace continuously tripping safety switch...

Old 12-06-13, 10:45 AM
Thread Starter
Join Date: Dec 2013
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Furnace continuously tripping safety switch...

This might not be a strictly do-it-yourself question...

We have a relatively new oil furnace (around 5 years old). The burner is a Beckett AFG and the controller unit is a Beckett R7184B. This is our second winter in this house. The furnace is serviced regularly by the company that provides us with oil. About 4 weeks ago, the furnace stopped working. The temperature in the house kept on dropping, the thermostat was reporting that it was trying to run the furnace, but the furnace would not kick on and the LED on the controller unit, next to the reset button, was flashing.

I called the service centre and was told that I should push the button to reset the system.

After doing this, everything was fine for about two days after which the system tripped again. This time around a technician was dispatched to our house. He did a "full" reset by holding the button down for around 60 seconds, then checked for air in the line (there was none), replaced the nozzle and serviced the unit (we were due for it according to their schedule). I asked the technician and the servicing involves cleaning and checking the electrode gap.

The furnace then worked for another 2-3 days and then tripped again. We had another technician dispatched to our house, he checked everything again and decided on replacing the thermostat. Since the technician was not sure how to wire up the new thermostat, it was initially wired into the controller unit with 2 wires and the thermostat upstairs was set to always have the fun running. This worked fine for a week and then another technician was dispatched to hook it up upstairs.

After this was done the furnace worked for about 2 days and once again started tripping the safety. Another technician, this time around they replaced the controller unit (box with green led and reset button).

A few days later they came in and replaced the photocell, then a few days later the ignition transformer and now we are waiting for a chimney cleaning.

The furnace seems to fire without any issues after the reset button is pressed and the flame is a nice bright yellow colour. After resetting it, it will run for around 5 minutes and then cut out and trip the safety again (without actually reaching the desired temperature).

At this point the oil company replaced around $500 worth of parts with another $200 for labor. We are not being charged for any of this since we have the service agreement with them, but at the same time sitting around in a house that is at 55 degrees with a small portable electric heater being moved around from room to room is getting old really quickly.

Is there anything else that I could potentially suggest to them? I'm starting to think that these guys don't really have a clue and are just throwing parts at it.
Old 12-06-13, 05:28 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 12,674
Received 40 Upvotes on 38 Posts
If the safety is tripped when the service person gets there it is a lot easier to troubleshoot. The service tech should be able to tell from the color of the flame if there is extra oil in the chamber or not. If there is, I would suspect the ignition transformer.

Has anyone checked how much vacuum the pump is pulling? How about an ohm reading on the cad cell?

The next time you have to reset it, stay with the furnace & keep detailed notes (pay particular attention to any odd sounds) until it the safety trips, then reset the safety right away. Let me know what happens.
Old 12-06-13, 09:38 PM
user 10's Avatar
Join Date: Mar 2004
Location: NA
Posts: 1,821
Received 56 Upvotes on 49 Posts
I don't know much about oil, but the flashing led is probably trying to tell you something -> error codes might be printed on the schematic.
Old 12-07-13, 06:17 AM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 12,674
Received 40 Upvotes on 38 Posts
No blink codes on most oil burners other than lockout. Some don't even have that.

If that burner has a solenoid on the fuel pump, the coil could be breaking down. If that happens, the valve will close thus killing the flame & causing the control to lockout. I've had that happen once.
About the only way someone is going to catch it until it fails completely is to be watching when it happens.

Thread Tools
Search this Thread
Ask a Question
Question Title:
Your question will be posted in: