Furnace not powering on


  #1  
Old 12-08-13, 07:20 AM
D
Member
Thread Starter
Join Date: Dec 2013
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
Furnace not powering on

Hi guys,

I have 2 Trane xl90 units in my house one for each floor. The first floor furnace is not powering on at all ..no blinking error lights, no clicking no sound at all. Here's what I have done so far:

*checked circuit breaker. -- no problem found
* checked the fuse on the furnace power on/off button -- no problem found
* I was able to manually turn the thermostat dial and the blower started
*disconnected the board and tested on the working unit and it worked
* disconnected the relay and tested on the working unit and it worked
*disconnected the thermodisc and tested on working unit and it worked

Where can the problem be if the board worked when tested on another unit? But when it's plugged to the non working unit it displays no lights as if no electricity is passing through..


Please help


Thank you
 
  #2  
Old 12-08-13, 07:45 AM
lawrosa's Avatar
Super Moderator
Join Date: Dec 2010
Location: Galivants Ferry SC USA
Posts: 15,988
Received 84 Upvotes on 76 Posts
You have 120v to the unit? I would think as you got the blower going

Is there a transformer, and you check for 24v there? Or does this have a module?

Is there any light on to show the board has power?

Let us know
 
  #3  
Old 12-08-13, 08:08 AM
D
Member
Thread Starter
Join Date: Dec 2013
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
I moved the dial on the thermostat and the blower comes on but not the inducer. As for the control board no lights at all. I tested the board and it working on the other unit

I attached a photo of the furnace
 
Attached Images  
  #4  
Old 12-08-13, 08:23 AM
D
Member
Thread Starter
Join Date: Dec 2013
Posts: 3
Upvotes: 0
Received 0 Upvotes on 0 Posts
I have a feeling it's the 24v transformer
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: