Bryant 310 with error code 33


  #1  
Old 01-09-14, 12:00 PM
Y
Member
Thread Starter
Join Date: Jan 2014
Location: USA
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Bryant 310 with error code 33

So I have a 6 year old Bryant model 310 and this past week I've been getting code 33. I'm in Indiana and it was about -15 degrees. I changed the air filter, which wasn't even a month old, but that didn't help. Now the temp here has warmed up some to about 25, but I'm still getting code 33 but not all the time. The furnace is able to keep up with the demand for heat now and sometimes when it shuts off it is fine and the led is constantly on. Other times it will shut down and flash code 33. I have also watched it flash code 33, then clear the code and not turn on for awhile until there is a call for heat. I had the blower motor replaced in Nov. 2010 and I checked it now and it spins freely. I feel like this could have been going on for quite some time without me knowing it since the furnace is able to keep up with normal cold temps. Any suggestions on what may be the issue?
Thanks
 
  #2  
Old 01-15-14, 09:40 PM
J
Member
Join Date: Jan 2014
Location: united states
Posts: 36
Upvotes: 0
Received 0 Upvotes on 0 Posts
If i remember correctly, i believe the error code 33 is "Limit Fault Circuit". ensure that your blower is on the correct speed, filter is not dirty and that your evaporator coil is clean. anything restricting airflow can cause your high limit switch to trip. hope this helps
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: