Oil - sounds like it's running but no heat...


  #1  
Old 01-09-14, 06:03 PM
V
Member
Thread Starter
Join Date: Jan 2014
Location: U.S.A.
Posts: 7
Received 0 Votes on 0 Posts
Oil - sounds like it's running but no heat...

So I can hear the typical 'circulation water drip' sound my heat usually makes whenever it kicks on... but the temperature just keeps going down.

It's oil heat, a Burnham boiler (you can see the temp is all the way down even though my thermostat is set very high), a Beckett burner (I've already tried hitting the reset button)... and you can see there is oil in the tank. We have old school radiators but I really have no idea what that means in terms of the heating system so I included a photo of that also hah.

Some background - on Jan 1st, we ran out of oil and the tank had to be primed before it was filled... could that affect things now 9 days later? What do I do now? - Thanks!

Name:  IMAG0630.jpg
Views: 370
Size:  23.6 KBName:  IMAG0633 (1).jpg
Views: 306
Size:  39.2 KBName:  IMAG0637.jpg
Views: 364
Size:  42.5 KBName:  IMAG0639.jpg
Views: 343
Size:  42.5 KBName:  IMAG0640.jpg
Views: 333
Size:  36.9 KB
 
  #2  
Old 01-10-14, 09:01 AM
V
Member
Thread Starter
Join Date: Jan 2014
Location: U.S.A.
Posts: 7
Received 0 Votes on 0 Posts
So it was the primary controller... although to make things far more complicated. Right before the tech arrived I went to turn the heat back on at the thermostat - which promptly fell out of the wall and broke.

Fortunately I had another thermostat (Nest) that I was meaning to install anyway.
 
  #3  
Old 01-10-14, 07:19 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 14,401
Received 37 Votes on 35 Posts
Be careful not to drop that Nest. Cha-Ching
Good to hear you got the boiler up & running.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: