Carrier 58SS Short Cycling

Reply

  #1  
Old 03-05-14, 01:50 PM
N
Member
Thread Starter
Join Date: Mar 2014
Location: USA
Posts: 1
Received 0 Votes on 0 Posts
Carrier 58SS Short Cycling

Hey guys, I have an older Carrier 58SS that is short cycling.

With the thermostat calling for heat, the inducer starts up. Then the gas for the pilot light and a spark to light the pilot both start, followed by the pilot light igniting. The spark quits ticking shortly after the pilot lights.

About a minute after the pilot lights, the main burners kicks on and lights. At that point the burners run for 8-10 seconds and shut off. About a minute later the process repeats.

I have cleaned the entire system fairly well. Especially the 3 wire ignitor. Where should I go from here?
 
Sponsored Links
  #2  
Old 03-06-14, 03:40 PM
J
Member
Join Date: Jan 2014
Location: united states
Posts: 37
Received 0 Votes on 0 Posts
Check flame sensor is clean and registering proper milliamps. If that is good you may be losing 24v check pressure switches, limits, gas valve and power off control board, also be sure the nipple on the inducer housing is not blocked. Hope this helps.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: