Carrier Weathermaker 8000 Ignition Problem

Reply

  #1  
Old 04-23-14, 06:14 PM
Member
Thread Starter
Join Date: Apr 2014
Location: United States
Posts: 1
Upvotes: 0
Received 0 Votes on 0 Posts
Carrier Weathermaker 8000 Ignition Problem

Hi

we have a Carrier Weathermaker 8000 Ignition Problem with a code 34. we replaced the ignitor and its still not glowing.

There are what should is the sequence:-

1. Main blower comes on for 90 sec
2. Inducer motor comes on for 20 sec
3. Heating element turns does not turn on

at this point I am not sure what else to look at to help diagnose the issue.

any suggestions would be appreciated.

Thank you.
 
Sponsored Links
  #2  
Old 04-24-14, 05:39 PM
user 10's Avatar
Member
Join Date: Mar 2004
Location: NA
Posts: 1,878
Received 20 Votes on 15 Posts
The error codes should be listed on the schematic. (on blower compartment access panel)

The most likely errors in your case are...

1. Pressure switch stuck open -> venting issue, badly cracked heat exchanger, bad pressure switch (don't change the pressure switch, it's unlikely to be bad)

2. Flame not sensed -> in this case, you have to see if the igniter is getting power when it should. Do you have a volt meter and know how to use it?
 
  #3  
Old 04-24-14, 05:44 PM
user 10's Avatar
Member
Join Date: Mar 2004
Location: NA
Posts: 1,878
Received 20 Votes on 15 Posts
re: main blower comes on for 90 sec - has it always done this?
 
  #4  
Old 04-24-14, 07:47 PM
Member
Join Date: Nov 2004
Location: USA
Posts: 46
Upvotes: 0
Received 0 Votes on 0 Posts
Carrier will run the blower motor for 90 seconds on power up if there is a call for heat.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: