Tempstar 7000, rollout opens with no flame roll out

Reply

  #1  
Old 10-24-14, 12:06 PM
K
Member
Thread Starter
Join Date: Oct 2014
Location: USA
Posts: 1
Received 0 Votes on 0 Posts
Tempstar 7000, rollout opens with no flame roll out

Tempstar 7000, model NUGK075DG09

The problem is the rollout switch keeps opening, but no flame roll out. However, the sheet metal where the limit control is mounted is hot enough to cook eggs. Limit control and rollout switch check fine, but I replaced them anyway. Blower fan blows hard, good strong heat comes out the house vents. All intake vents are unobstructed, new furnace filter.

Call for heat from thermostat. Combustion blower starts, ignition, spark, burners light, no roll out of flames. Nice blue flame in the fire box. Furnace makes it through one or two cycles of heating before it gets hot enough to open the rollout switch. Pushing the little button on the rollout gets everything up and going again, but of course the rollout opens once again.

Am I down to taking apart the furnace and having a look at the heat exchanger, or is there something else I can check first?

As a side note, my transformer puts out 30V, but the house voltage has been at 127, so when I check voltages, I look for 30V.
 
Sponsored Links
  #2  
Old 10-24-14, 12:59 PM
S
Member
Join Date: Feb 2014
Location: USA
Posts: 2,104
Received 0 Votes on 0 Posts
You might not see flames actually touching the roll out, but if the surface around the roll out gets hot enough to trip the switch, then I would consider it as flame roll out. Check for vent blockage.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: