Reversed Polarity On My Furnace?


  #1  
Old 11-25-14, 11:54 PM
B
Member
Thread Starter
Join Date: Nov 2014
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Question Reversed Polarity On My Furnace?

I have a Janitrol GMP0753 that is 14 going on 15 years old.

Whenever I start up my furnace everything works up until the igniter is supposed to stay on. It glows for about a second then cuts off, shortly after that the light blinks rapidly then the furnace tries to light itself again but repeats the same problem. I looked up what this meant on the Janitrol (now goodman) website and it said this was a code for "Reversed 115 VAC Polarity or Open Hot Surface Igniter Circuit". What should I do about this? Any help would be greatly appreciated.
 
  #2  
Old 11-26-14, 12:08 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 63,843
Received 3,748 Upvotes on 3,361 Posts
Welcome to the forums.

What actual code did you get ?
 
  #3  
Old 11-26-14, 12:15 AM
B
Member
Thread Starter
Join Date: Nov 2014
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
Not quite sure what you mean. the light in my furnace blinks constantly until it tries restart the process. I read from this website Goodman Diagnosis Code Identification System that this meant a polarity or igniter curcuit problem.
 
  #4  
Old 11-26-14, 12:30 AM
Houston204's Avatar
Forum Topic Moderator
Join Date: Oct 2009
Location: Texas
Posts: 6,480
Received 90 Upvotes on 83 Posts
If no one has been tampering with your wiring I would be surprised to see the problem anything other than the control board for a rapid flashing LED.

Measure from the black incoming power wire to the body of the furnace for 120 volts AC. Measure from the incoming white power wire to the furnace body for less than 3 volts AC.

I would also check the ground connections.
 
  #5  
Old 11-26-14, 06:18 AM
Houston204's Avatar
Forum Topic Moderator
Join Date: Oct 2009
Location: Texas
Posts: 6,480
Received 90 Upvotes on 83 Posts
A rapid flash usually occurs long before the hot surface ignitor glows. Are you sure it isn't flashing an ignition proving failure instead of a constant fast flash?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: