American standard furnace only runs for a few minutes then turned off?

Reply

  #1  
Old 02-17-15, 08:26 AM
Member
Thread Starter
Join Date: Feb 2015
Posts: 2
Received 0 Votes on 0 Posts
Exclamation American standard furnace only runs for a few minutes then turned off?

Gas to the furnace was turned off after 3 minutes of burn time, then blinks 4 times, the furnace will restart again and turn ordinary LED flashes!!

This cycle repeats until the temperature reaches the current set of heat as nothing goes wrong! What needs to be changed here? Please HELP

** it only happened since yesterday.

Model number: CUB100A948C4
 
Sponsored Links
  #2  
Old 02-17-15, 09:43 AM
Member
Join Date: Feb 2014
Location: USA
Posts: 2,104
Received 0 Votes on 0 Posts
Look for the codes on the inside of the blower cover. Let us know what 4 blinks means.
 
  #3  
Old 02-17-15, 11:14 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 52,589
Received 337 Votes on 315 Posts
Welcome to the forums.

Four flashes indicates an open high heat safety stat. This usually indicates a poor airflow problem. The first place to start is to check the air filter and replace if dirty. Make sure the return vents aren't blocked and that too many supply registers aren't closed off.

If those all check out ok you may have an A/C coil that has become plugged with dust.
 
  #4  
Old 02-20-15, 12:30 PM
Member
Thread Starter
Join Date: Feb 2015
Posts: 2
Received 0 Votes on 0 Posts
Thank you PJmax, I have replaced the air filter and the problem is solved! It's really easy, but I never knew.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: