Olsen Ultramax Gas Furnace


  #1  
Old 03-19-15, 08:46 PM
R
Member
Thread Starter
Join Date: Mar 2015
Location: Canada
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Olsen Ultramax Gas Furnace

I am having a problem with my Olsen Ultramax furnace (installed early 90's). Furnace will ignite but within a few minutes shut down although blower fan continues to operate continually blowing cold air. Fault light in furnace stays on steady and indicates control needs to be replaced according to chart inside. My questions are..... Is fault light a reliable way to diagnose problem with furnace? Is there a possibility that there are other components contributing to the problem? If it is only the control, is this something I can change myself as it looks fairly easy. Control is a White Rodgers 50A50-216.......Thanks Richard.

Should have also asked... are there any tricks for getting it working for tonight.
 
  #2  
Old 03-19-15, 11:55 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 71,686
Received 3,338 Upvotes on 2,997 Posts
Welcome to the forums.

Try cleaning the flame sensor rod. It will be a metal rod attached to the furnace with a one screw bracket and a single wire. Remove it and clean it with a scotch brite pad or steel wool. It needs to be very shiny.

Also, make sure you have a clean air filter in place. Make sure too many registers aren't closed off and that the return grille(s) aren't blocked.

Other than that..... if the red light comes on solid.... it does indicate a problem with the control board.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: