Thermo Pride oil furnace


  #1  
Old 10-04-15, 10:47 AM
B
Member
Thread Starter
Join Date: Oct 2015
Location: usa
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thermo Pride oil furnace

I have a thermo pride oil furnace that is 13 years old but has only been used for 3 or 4 heating seasons due to wood stove my main heat source. The unit will not run now. When unit is started the reset trips when the burner doesn't fire and get up to temp. It would appear that the pump is not drawing fuel. I can crack the air bleed screw and pull a good flow of fuel but when I close the bleeder and the furnace/pump shuts off the fuel drains back to the tank. Pump bad?
 
  #2  
Old 10-04-15, 10:52 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 61,710
Received 3,340 Upvotes on 2,999 Posts
Does it fire after you bleed it ??

Pump bad.... possibly. Leak.... more likely.
 
  #3  
Old 10-04-15, 04:21 PM
F
Member
Join Date: Mar 2006
Location: Wet side of Washington state.
Posts: 16,321
Received 37 Upvotes on 29 Posts
Need a whole lot more information.

Is the fuel level in the tank above, below or at approximately the same level as the pump? How old is the fuel? What type of fittings are used, i.e. compression, threaded pipe or flared copper tubing? Is there a check valve assembly in the fuel suction line? Is this a "two pipe" or a "single pipe" system? When was the last time the unit was fired? When was the last time the burner was professionally services with a fuel filter change and a nozzle change plus combustion testing?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: