Thermostat not recognizing temp


  #1  
Old 12-19-15, 05:03 AM
L
Member
Thread Starter
Join Date: Dec 2015
Location: usa
Posts: 1
Received 0 Votes on 0 Posts
Thermostat not recognizing temp

My thermostat will not recognize the temp in my home when raised above 66Degress. Tried raising it 2 deg and it rain for over 30 min and temp did not adjust at all. set at 68, house was 66, lowered to 67 and system shut off.
this is a new honeywell programable thermostat i just purchased to replace a honeywell wifi programable stat that was doing the same thing.
i have a trane xl 80 2 stage gas furnace. any ideas?
 
  #2  
Old 12-19-15, 07:10 AM
S
Member
Join Date: Feb 2014
Location: USA
Posts: 2,101
Received 0 Votes on 0 Posts
When it was running was it blowing warm air?
 
  #3  
Old 12-19-15, 07:33 AM
GregH's Avatar
Super Moderator
Join Date: Jan 2001
Location: Manitoba
Posts: 10,234
Received 65 Votes on 60 Posts
Welcome to our forums!

Need more info.
When you set the temperature at 68 and the house did not get that high did the furnace shut off or keep running?
If the furnace shut off could it have shut off because the filters are dirty and overheated the heat exchanger?

My Honeywell non-programmable thermostat has a "heating" icon that flashes when it is calling for heat......does yours and does it flash when the furnace will not heat to 68?
If your icon is flashing and the furnace shuts off it could be a furnace problem, especially since this is the second thermostat.

What is the full model number of your thermostat?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: