Bryant 95s strange behavior

Reply

  #1  
Old 02-04-16, 10:52 AM
Andrew's Avatar
Member
Thread Starter
Join Date: Apr 2003
Location: USA
Posts: 975
Received 1 Vote on 1 Post
Bryant 95s strange behavior

In our new (to us) home, we have a Bryant Evolution 95s natural gas furnace that did something strange last night. Before bed, I noticed that the room temp was 64, even though the stat was set for 70. The furnace was not running. I checked the status lights on the furnace control board & found one amber light lit (not blinking). Unsure of the meaning of that, I cut power to the furnace for a minute, then turned it back on. No change. I then went back to the thermostat & moved the fan switch from AUTO to ON. That did bring the blower on. I then set it back to AUTO, and moved the mode switch from HEAT to OFF. After ten seconds, I moved it back to HEAT, and the furnace fired back up normally.

The furnace is six years old, spotlessly clean inside & out, and it's a quality installation. The inducer did conk out a couple of months ago, but that was replaced under warranty, and has been working fine.

Any ideas?

Thanks,
Andy
 
Sponsored Links
  #2  
Old 02-04-16, 12:42 PM
SeattlePioneer's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2007
Location: Seattle, Wa
Posts: 5,503
Received 0 Votes on 0 Posts
Not enough information to even be able to speculate.


Take the cover off the burner compartment of your furnace. Turn up the thermostat and observe and understand the SEQUENCE of events which occur before you get heat.


The next time this happens, go down to the furnace and see how far the furnace is in that sequence.

Hint: When the thermostat calls for heat, the first thing you should notice is that a small motor called the inducer motor should start up and come up to speed.

If that doesn't happen, the thermostat may not actually be switching on the furnace, the furnace circuit board may not be turning on the inducer motor, or the inducer motor may be bad and not turning on properly despite having the proper power to it.
 
  #3  
Old 02-04-16, 04:00 PM
Andrew's Avatar
Member
Thread Starter
Join Date: Apr 2003
Location: USA
Posts: 975
Received 1 Vote on 1 Post
Thanks for your reply. I do understand the basic sequence of events in this furnace, and I understand what everything does. Unfortunately, I do not know whether the furnace had been running just prior to this condition, or if it happened upon an attempted start. What I do know is there was NO activity at the furnace when there was a call for heat. Only the amber status LED was lit, and I haven't found any charts showing what that means in a Bryant furnace. If anyone knows the codes for this furnace, I'd appreciate the info.
BTW, I sure miss my simple old boiler in the old house
Thanks,
Andy
 
  #4  
Old 02-04-16, 05:19 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 56,394
Received 748 Votes on 703 Posts
You didn't leave the model number so this is a generic guide. I believe amber light on means ok and not calling for heat. The green one would also have to flash for a fault. Your furnace stores codes that can be retrieved. It's covered in this service brief.

hvac partners/docs/1009/Public/0D/SM355CAV-01.pdf

Does your furnace have a hot surface igniter or intermittent pilot ?
 
  #5  
Old 02-05-16, 06:39 AM
Andrew's Avatar
Member
Thread Starter
Join Date: Apr 2003
Location: USA
Posts: 975
Received 1 Vote on 1 Post
Thanks for the info, PJ
I'm at work, but will check for the actual model number when I get home tonight. It has a hot surface ignitor.
As I think about the series of events, I'm starting to think it may have been a thermostat glitch, rather than the furnace. I'll dig into it some more this weekend.
Andy
 
  #6  
Old 02-05-16, 01:15 PM
SeattlePioneer's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2007
Location: Seattle, Wa
Posts: 5,503
Received 0 Votes on 0 Posts
<<Unfortunately, I do not know whether the furnace had been running just prior to this condition, or if it happened upon an attempted start. >>


Intermittent problems are the bane of repairman ----and DIYers too.

What you can do is to turn up the thermostat repeatedly until the furnace fails to ignite properly again. You need to be down at the furnace observing the sequence of operation when that happens.

It might take 20-40 cycles before that fails again.

Generally speaking, intermittent problems continue to recur with increasing frequency until the part going bad quits completely. So the problem, whatever it is, will probably be back.
 
  #7  
Old 02-13-16, 09:49 PM
Andrew's Avatar
Member
Thread Starter
Join Date: Apr 2003
Location: USA
Posts: 975
Received 1 Vote on 1 Post
Solved!

After another episode of this issue, I began very systematically checking everything, and lo and behold, I found a broken wire behind the thermostat. It usually made contact, but not always. Fortunately, there was enough slack that I was able to cut off the damaged section & reconnect it without issues.
Andy
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: