Furnace will not start (Lennox G43UF)


  #1  
Old 10-15-16, 08:10 PM
T
Member
Thread Starter
Join Date: Oct 2016
Posts: 1
Received 0 Votes on 0 Posts
Furnace will not start (Lennox G43UF)

I'm hoping someone out there can help me out. I had a technician come in last week to help me troubleshoot my furnace. Originally the blower (fan) was working but it wasn't heating up. He came in, tested the pressure switch and the gas valve. After 30 minutes of testing, he determined all the components are working fine however the control board needed to be replaced - it wasn't supplying the proper voltage to the other components. He quoted me $800 and I sent him on his way. I went online and found the exact same board for $200 and installed it myself - being very careful to wire it exactly as it was on the old board.

The LED's on the board are flashing slow simultaneously which indicates a "normal operations" but for some reason the furnace won't start. The unit is humming but the blower is sitting idle. I've searched every forum for an answer without any luck. I'm hoping a pro on this forum can help out a cold Canadian!

Appreciate your help!
 
  #2  
Old 10-16-16, 05:25 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 25,509
Received 961 Votes on 882 Posts
What is humming?

Here is the manual for your furnace. Page 41 has a troubleshooting flow chart. Page 50 lists the blink codes and both lights blinking slow is not "normal operations" it indicates a problem.
 
  #3  
Old 10-16-16, 09:11 AM
S
Member
Join Date: Feb 2014
Location: USA
Posts: 2,101
Received 0 Votes on 0 Posts
I don't know how he could test those parts if the control board was bad. If you have a meter test between W and C on the control board. If the stat is calling for heat then you should have 24 volts. Let us know.
 

Last edited by skaggsje; 10-16-16 at 09:11 AM. Reason: correction
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: