Rheem 90 Plus - won't ignite


  #1  
Old 11-03-16, 12:16 AM
N
Member
Thread Starter
Join Date: Nov 2016
Posts: 3
Received 0 Votes on 0 Posts
Rheem 90 Plus - won't ignite

Blower starts
Ignition thing glows
No gas ignition
Main fan/blower begins as if nothing is wrong
Fan stays on for a minute or two and shuts off

The furnace is the only gas appliance in the house so I can't really test elsewhere with regards to the gas supply. I tested the gas valve wires during this ignition cycle and couldn't get any VAC to register on the meter.

Serial number has the furnace as a 1995 product.

Name:  20161103_065629115_iOS.jpg
Views: 2162
Size:  51.3 KB
 
  #2  
Old 11-03-16, 12:24 AM
N
Member
Thread Starter
Join Date: Nov 2016
Posts: 3
Received 0 Votes on 0 Posts
Also, there are two green lights in the lower compartment that stay that way throughout.
 
  #3  
Old 11-03-16, 06:21 AM
R
Member
Join Date: Oct 2016
Posts: 2,181
Received 124 Votes on 118 Posts
Is the board outputting voltage to the gas valve during trial? What code is the furnace shutting down on? Is gas on?
 
  #4  
Old 11-03-16, 11:31 AM
SeattlePioneer's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jul 2007
Location: Seattle, Wa
Posts: 5,499
Received 0 Votes on 0 Posts
You need to be able to verify that you have good gas pressure to the electric gas valve. On way to do that is to shut off the manual gas valve at the furnace, open the union or flex connector, and briefly turn the gas back on for a second or so.

If that is OK, you need to check to see if you have 24 VAC to the electric gas valve being switched on after the HSI heats up. If you do, you may have a burned out gas valve. If you don't, a failed circuit board.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: