Lennox Furnace not heating

Reply

  #1  
Old 10-16-17, 01:05 PM
Member
Thread Starter
Join Date: Oct 2017
Location: Canada
Posts: 3
Received 0 Votes on 0 Posts
Lennox Furnace not heating

Hello,

I have a Lennox Elite series Surelight furnace. Model: 90UGFA2-50-6.

I am having two issues.

First issue I am having is with the Furnace FAN. It won't turn on when thermostat is set to HEAT mode and FAN is in AUTO mode. If I turn the FAN to ON it works fine.

I had this issue last year and I manually restarted the furnace and it worked fine but I am having the same issue this year again and the manual restart of the furnace hasn't helped.

Second issue which started yesterday is I have no HOT AIR now even if I put the FAN in ON mode.
When I put the FAN into AUTO or ON mode and observe the furnace, I do hear the inducer motor turning ON which shuts down after around a minute.

Any advise would be greatly appreciated.


tx
 
Sponsored Links
  #2  
Old 10-16-17, 01:19 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 52,668
Received 340 Votes on 318 Posts
Welcome to the forums.

Surelight is the name on a control board. What is the part number on that Surelight control board ?
I'm showing that furnace to use a fan control board which is not common when there is a furnace board used.
 
  #3  
Old 10-16-17, 06:30 PM
Member
Thread Starter
Join Date: Oct 2017
Location: Canada
Posts: 3
Received 0 Votes on 0 Posts
I put the furnace and FAN to ON and looked through the FLAME SIGHT GLASS and I didn't notice any light or fire. Am I supposed to see any fire or lights inside?

This is my first time dealing with a furnace so I am not sure on that.

Another thing I would like to share is the Diagnostic lights status on the control board. When Inducer is ON I see both diagnostic lights blinking which seemed normal to me based on few videos I watched on youtube. When Inducer shuts down the diagnostic light 1 turns off while light 2 keeps on blinking.

I am not sure if it helps in any way in narrowing down what I might be experiencing.

Any advise is greatly appreciated.

tx
 
  #4  
Old 10-16-17, 08:23 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 52,668
Received 340 Votes on 318 Posts
User manual... lennox pros/docs/Technical/503629M.pdf

Your code is showing a problem with the pressure switch. It could be a blockage in the main flue or a problem with the vacuum connection between the pressure switch and the draft inducer blower.

This can be a tricky DIY repair. If you have a gas provider.... I'd call them for service and cleaning.

Manual covering the surelight ignition system....
ac furnace parts/service manuals/surelight.pdf
 
  #5  
Old 10-17-17, 08:01 AM
Member
Thread Starter
Join Date: Oct 2017
Location: Canada
Posts: 3
Received 0 Votes on 0 Posts
The issue was the inlet pipe filled with stones and debris by my toddlers. I took everything out and the furnace is working like new.

thanks a lot for all the help guys, much appreciated !!!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: