Gas Furnace Start issues

Reply

  #1  
Old 10-31-17, 10:04 AM
Member
Thread Starter
Join Date: Oct 2017
Location: United States
Posts: 2
Upvotes: 0
Received 0 Votes on 0 Posts
Gas Furnace Start issues

Model: Ruud UGDG-10EBRJR
Thermostat: Honeywell RTH3100C

I am having issues with my furnace starting.

Sequence as follows:
-Blower fan starts
-Vent fan starts (runs for about 30 seconds)
-Element begins to glow(about 20 seconds)
-Solenoid for gas clicks, and almost immediately the element disengages and nothing ignites.

Cycle continues and will enter into lockout, then attempt to start again. When I "reset" the system ( by leaving the panel off and the switch open for about 5 minutes), the burners will ignite and stay lit. However, when it reaches the set temperature and turns off, it will not re-ignite to reheat.

In addition, the AC was running simultaneously, but I disconnected the relay for the condenser to alleviate that problem. It is temporary until I can get this all sorted out.
 
Sponsored Links
  #2  
Old 10-31-17, 10:23 AM
Houston204's Avatar
Forum Topic Moderator
Join Date: Oct 2009
Location: Texas
Posts: 7,370
Received 10 Votes on 8 Posts
https://customer.honeywell.com/resou.../69-2340ES.pdf

That is a heat pump thermostat. It will run the AC with a heating demand. You need a different thermostat.

It also sounds like you need a new furnace control board.
 
  #3  
Old 10-31-17, 10:54 AM
Member
Thread Starter
Join Date: Oct 2017
Location: United States
Posts: 2
Upvotes: 0
Received 0 Votes on 0 Posts
I will replace the thermostat for the right one.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes